Cubic Castles Isn't Working On My PC

bunnyboo61068bunnyboo61068 Member
in Bug Reports 0.40 Karma
So recently I have been going on the game and I try to get on the application and it loads fine all the way to the login screen so I click log in and the it sends me straight to the crash report so I send the crash report, but still every day it does the same thing, either does that or it loads me on without a head and all you see on my screen is me with no head at all and on other people all you see are their accessories and I just wanted to know if someone can help me try to fix this or help me find out whats causing it and I know it isn't my internet connection because my sisters get on just fine and one PC while the other one has a mobile device.

Comments

  • bunnyboo61068bunnyboo61068 Member
    0.40 Karma
    I tried that and it still won't load.
  • BJDwareBJDware Down underRetired Moderator
    108.70 Karma
    What client are you using?
    If steam or windows, record your login details and delete the "cubic" appdata folder, uninstall CC, then re-install.

    If the problem persists, contact the support team @ http://help.cubiccastles.com/support/
  • bunnyboo61068bunnyboo61068 Member
    0.40 Karma
    Okay I'll try it and I'll see if it works I'll tell you if it doesn't work because i tried to get on this morning and it didn't work.
  • bunnyboo61068bunnyboo61068 Member
    0.40 Karma
    How do you do that p.s sorry for responding so late :/
  • TheDJDude12TheDJDude12 Member
    3.15 Karma
    what you can do is press the Windows key + r then type in %appdata% and then browse and delete the Cubic folder
  • 0.65 Karma
    This happened to me too, I tried everything and still would crash. I then made a new account on my PC and installed it, and it worked!
  • NanoSlime_NanoSlime_ Member
    5.95 Karma

    How do you do that p.s sorry for responding so late :/

    On windows, uninstall Cubic Castles, then go to the start menu or the search function on Cortana (if you are on windows 10) then type %appdata% then find the folder named Cubic, delete the folder then reinstall Cubic Castles.

    Hope this helps.
  • FrenchyyyFrenchyyy Member
    15.00 Karma
    Same happened to me, I did solve it, then came back...

    So, I wasn't playing CC from a long time, then yesterday I tryed to play it on PC, launched the app, logged-in and clicked Play... The game crashed and asked me to send the report to the developers. So I did, and also I screenshotted the report details and sent them to the support center... After 12h they answered saying that the crash was caused by DirectX... They told me to install last version of DirectX... (But mine was DirectX 12.0 - the new version - that I was playing on before 2 months...)... I uninstalled DirectX and reinstalled. It seemed to work for one day - or even less than that... But in that little time too I had some problems: all the new items were shown as Broken Links and all the persons wearing them were naked at my screen (camo shirts and pants)...
    Then today it started crashing again, so I tryed another method, at my own risk, I uninstalled the game, deleted all Cubic Castles files (Search > %appdata% > Cubic > and I deleted this folder), then I reinstalled... For the first connection, everything came back to normal, as it didn't crah and I didn't have any problem with the new items (I had a camo shirt on the first row of my inventory)...
    Then another crash... And now I can play from time to time as the problem comes and goes, but I still can't use/see/trade/enjoy the new items :( ...


    So I kindly ask the developers to solve this issue... And in these some days before summer vacation finishes ;)
  • 2.10 Karma
    I had same prob last 2 years
Sign In or Register to comment.